BlackBerry 7 OS not supported on current/older BlackBerry devices

0

Bad news for current BlackBerry users, OS 7 is not going to be supported on current or older BlackBerry smartphones.  The news might seem to be a little obvious to some, but RIM came out and officially said it during some Q&A this morning after introducing the BlackBerry Bold 9900 series.  The reasoning for the limitation seems to be obvious.  RIM has taken a big jump in hardware, and it looks like OS 7 is demanding in power, requiring a faster processor and “liquid graphics” as they had mentioned.

Share.

About Author